广告位招租

centos7 dd ros系统教程/一键脚本

2,817次阅读
一条评论

准备条件:

纯净centos7 系统(debian/ubuntu16通过类似)([全自动]debian/centos/ubuntu 一键网络重装系统 – 猫不腻 (maobuni.com)
更新系统:yum update
安装wget : yum install wget -y
关闭firewalld: systemctl stop firewalld.service && systemctl disable firewalld.service

一、通用单网卡方案 (适应于绝大多数VPS)

下载镜像
wget https://download.mikrotik.com/routeros/6.48.3/chr-6.48.3.img.zip -O chr.img.zip

解压缩
gunzip -c chr.img.zip > chr.img

挂载镜像
#注意:先用命令 fdisk -lu chr.img 查看start值是否为1,不是,则用当前数字 *512,替换下面命令中的offse值
mount -o loop,offset=512 chr.img /mnt

获取地址与网关 与 赋入变量
#有的网卡不是eth0 可以用ifconfig命令查看或者ip addr 查看,使用对应网卡命令即可

ADDR0=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1`
ADDR0=`ip addr show ens3 | grep global | cut -d' ' -f 6 | head -n 1`
GATE0=`ip route list | grep default | cut -d' ' -f 3`
mkdir -p /mnt/rw
\echo "/ip address add address=$ADDR0 interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATE0
" > /mnt/rw/autorun.scr

卸载镜像

umount /mnt

立即重新挂载所有的文件系统为只读

echo u > /proc/sysrq-trigger

DD ros镜像(有的机器硬盘并不是/dev/sda而是/dev/vda,需要提前使用fdisk -lu)

dd if=chr.img bs=1024 of=/dev/vda
reboot
(reboot失效可用下面命令)
立即重新启动机器

echo b > /proc/sysrq-trigger

安装好之后用有vnc的可以登录console看到安装界面,默认账号是admin,默认密码是空。尽快登录修改密码

一键脚本

wget https://download.mikrotik.com/routeros/6.48.3/chr-6.48.3.img.zip -O chr.img.zip && \
gunzip -c chr.img.zip > chr.img && \
mount -o loop,offset=512 chr.img /mnt && \
ADDR0=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && \
GATE0=`ip route list | grep default | cut -d' ' -f 3` && \
mkdir -p /mnt/rw && \
echo "/ip address add address=$ADDR0 interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATE0
" > /mnt/rw/autorun.scr && \
umount /mnt && \
echo u > /proc/sysrq-trigger && \
dd if=chr.img bs=1024 of=/dev/vda && reboot

常见问题:
有些D完死活启不动连不上 是因为UEFI的缘故,跟脚本无关 请改用 ROS7.0Beta 版本 支持UEFI启动
wget https://download.mikrotik.com/routeros/7.0beta5/chr-7.0beta5.img.zip -O chr.img.zip

Ros 授权相关

Ros 系统是商业软件 ,本身是需要授权的,在没有授权的情况下使用,网卡限制速率(1Mbps),不过Ros CHR版本是支持免费试用的,只需要去官方网站 https://mikrotik.com/client 注册一个帐号,然后去邮箱获取帐号通过验证,接着返回到Ros系统  进入 System > License > generate new id 填入你刚刚注册的帐号登录即可,试用期是两个月时长,只要系统不进行更新,是可以一直免费试用下去的,功能不受限制。

SSH登录
一般NAT小鸡DD完ros后会自动设置好网络这些,只需要重启机器,然后使用xshell or putty ,连接NAT的IP,SSH端口号,用户名为admin,密码为空;登录到ros路由管理界面,输入/ip service set winbox port=映射端口, 可重新映射winbox端口;

使用winbox登录ros系统 并修改默认用户(ssh客户端登录为IP地址,ssh端口号,初始用户名和密码)

winbox 下载链接
默认登录名为:admin 默认密码为: 空
登录之后尽快修改权限,可新增用户(system>users add),然后禁用原admin用户;或修改必要端口(IP>firewall>service ports)
如果你使用的MAC地址登录的话,不需要输入端口

centos7

ROS 常用命令:

1、查看网卡接口: /interface  print

2、给网口添加IP地址: /ip address add address=192.168.1.254/24 interface=ether1

3、移除接口IP地址:  /ip address remove 0

4、重启系统:  /system reboot

5、关闭系统:  /system shutdown

6、恢复原始状态:  /system reset

7、查看IP配置:  /ip export    或  /ip address print

8、查看授权:  /system license print

9、重新映射winbox端口: /ip service set winbox port=映射端口

10、查看网卡名称: interface print

11、配置IP地址和网关: /ip address add address=IP地址/掩码 interface=网卡名

/ip route add gateway=网关地址

评论(一条评论)
载入中...